网站地图 - 培训课程最新更新 - sitemap - 设为首页 - 加入收藏
您的当前位置:中南教育信息网 > 培训课程 > IT认证 > H3C认证 > 正文

h3c交换机清除配置命令整理

来源:本站整理 编辑:中南教育信息网 时间:2017-06-05

  [Quidway]display mac-address ;显示地址表信息

  [Quidway-Ethernet0/2]port access vlan 3 ;当前端口加入到VLAN

  reboot ;交换机重启

  [Quidway]stp root {primary|secondary} ;设置为根或根的备份

  配置基于access的VLAN

  [SwitchA] dldp enable # 全局开启DLDP。

  在端口Ethernet1/0/1上启用IP过滤功能,防止客户端使用伪造的不同源IP地址对服务器进行攻击

  [SwitchA] display gvrp status ;显示GVRP的全局状态信息

  同端口学习到相同MAC地址的情况,可能会对MAC地址表的维护产生影响。

  [Quidway-Ethernet0/1]undo shutdown ;激活端口

  16、QinQ配置

  [DeviceA] link-aggregation group 1 service-type tunnel # 在手工聚合组的基础上创建Tunnel业务环回组。

  [Quidway-Ethernet0/2]port hybrid vlan vlan_id_list untagged ;设置无标识的vlan

   system-view

  [S3026-ui-vty0-4]authentication-mode password ;设置口令模式

  [Quidway-Ethernet0/1]duplex {half|full|auto} ;配置端口工作状态

  [ProviderA-Ethernet1/0/2] port access vlan 1000

  在以太网端口视图下添加MAC地址表项

  在添加MAC地址表项时,命令中interface参数指定的端口必须属于vlan参数指定的VLAN,否则将添加失败。

  [S3026-ui-vty0-4]set authentication-mode password simple 222 ;设置口令

  [SwitchA-GigabitEthernet1/1/1] speed 1000

  MAC地址老化时间的配置对所有端口都生效,但地址老化功能只对动态的(学习到的或者用户配置可老化的)MAC地址表项起作用。

  [Quidway-Ethernet0/2]port-mac start-mac-address ;配置以太网端口MAC地址的起始值

  [ProviderA-Ethernet1/0/1] port link-type hybrid

  [Quidway]interface vlan x ;进入接口视图

  提供了灵活的组网方案。

  [Sysname]display isolate port # 显示隔离组中的端口信息

  [ProviderA] interface ethernet 1/0/3 # 配置端口为Trunk端口,且允许VLAN1000和VLAN2000的报文通过。

  [Quidway]description string ;指定VLAN描述字符

  [SwitchA] display garp statistics [ interface interface-list ] ;显示GARP统计信息

  [Quidway-Ethernet0/1]speed {10|100|auto} ;配置端口工作速率

  如果某个聚合组中的端口同时属于某个隔离组,当在系统视图下直接删除该聚合组后,该聚合组中的端口仍将处于该隔离组中。

  [ProviderA-Ethernet1/0/3] qinq ethernet-type 8200 # 为与公共网络中的设备进行互通,配置端口添加外层Tag时采用的TPID值为0x8200。

  如果vlan参数指定的VLAN是动态VLAN,在添加静态MAC地址之后,会自动变为静态VLAN。

  [SwitchA-vlan-interface10] bfd min-echo-receive-interval 300

  [Switch-Ethernet1/0/1] mac-address security 0001-0002-0003 vlan 1 # 将Host 的MAC地址0001-0002-0003作为Security MAC添加到VLAN 1中

  H3C不但拥有全线路由器和以太网交换机产品,还在网络安全、云存储、云桌面、硬件服务器、WLAN、SOHO及软件管理系统等领域稳健成长。下面是小编整理H3C//503283.html">h3c交换机清除配置命令整理,欢迎大家参考!

  [Sysname-mst-region] region-name info

  8、STP配置

  通过端口绑定特性,网络管理员可以将用户的MAC地址和IP地址绑定到指定的端口上。进行绑定操作后,交换机只对从该端口收到的指定MAC地址和IP地

  [Quidway]monitor-port ;指定镜像端口

  [Quidway]vlan 3 ;创建VLAN

  [SwitchA] bfd echo-source-ip 123.1.1.1

  [ProviderB-Ethernet1/0/2] port access vlan 2000

  在Switch A上可以打开BFD功能调试信息开关,断开Hub和Switch B之间的链路,验证配置结果。验证结果显示,

  [SwitchA] display dldp 1 # 查看DLDP状态。

  [Quidway-Ethernet0/2]port hybrid pvid vlan ;设置vlan的pvid

  [ProviderA-Ethernet1/0/1] qinq vid 2000 # 将来自VLAN20的报文封装VLAN ID为2000的外层Tag。

  5、链路聚合配置

  [Sysname-mst-region] instance 1 vlan 2 to 10

  注意:所有端口缺省情况下都是允许VLAN1的报文通过的

  如果DLDP的工作模式为normal,则有收光的一端处于Advertisement状态,没有收光的一端处于Inactive状态。

  [ProviderB-Ethernet1/0/2] qinq enable # 配置端口的基本QinQ功能,将来自VLAN20的报文封装VLAN ID为2000的外层Tag。

  [Quidway]port mirror int_list observing-port int_type int_num ;指定镜像和被镜像

  [Quidway-Ethernet0/2]port hybrid vlan vlan-id-list { tagged | untagged } ;允许指定的VLAN通过当前Hybrid端口

  在添加MAC地址表项时,当前的端口必须属于命令中vlan参数指定的VLAN,否则将添加失败;

  [ProviderA-Ethernet1/0/3] port link-type trunk

  [ProviderB] interface ethernet 1/0/2 # 配置端口的缺省VLAN为VLAN2000。

  如果DLDP的工作模式为enhance,则有收光的一端处于Disable状态,没有收光的一端处于Inactive状态。

  私有VLAN配置

  [SwitchA] dldp interval 15 # 设置发送DLDP报文的时间间隔为15秒。

  注意:缺省情况下,所有Hybrid端口只允许VLAN1通过

  [SwitchA] display garp timer [ interface interface-list ] ;显示GARP定时器的值

  [Quidway]mac-address timer { aging age | no-aging } ;设置MAC地址表项的老化时间

  [ProviderA] interface ethernet 1/0/1 # 配置端口为Hybrid端口,且允许VLAN10,VLAN20,VLAN1000和VLAN2000的报文通过,并且在发送时去掉外层Tag。

  [ProviderB-Ethernet1/0/1] port link-type trunk

  如果包的vlan id与PVId一致,则去掉vlan信息. 默认PVID=1。

  10、GVRP配置

  [SwitchA] ip route-static 120.1.1.1 24 10.1.1.100 bfd echo-packet

  当隔离组中的某个端口加入聚合组时,该聚合组中的所有端口,将会自动加入隔离组中。

  Switch A能够快速感知Switch A与Switch B之间链路的变化。

  Customer A的VLAN10的报文可以和Customer B的VLAN10的报文经过运营商网络的VLAN1000转发后互通;Customer A的VLAN20的报文可以

  7、VLAN配置

  Provider A、Provider B之间通过Trunk端口连接,Provider A属于运营商网络的VLAN1000,Provider B属于运营商网络的VLAN2000。

  [SwitchA-Ethernet1/0/1] gvrp # 在以太网端口Ethernet1/0/1上开启GVRP

  12、端口隔离配置

  如果vlan参数指定的VLAN是动态VLAN,在添加静态MAC地址之后,会自动变为静态VLAN。

  配置基于Hybrid端口的VLAN

  # 在Switch A上打开BFD功能调试信息开关。

  [ProviderB-Ethernet1/0/1] port trunk permit vlan 1000 2000

  有的交换机上绑定的配置不一样

  [SwitchA-Ethernet1/0/2] dhcp-snooping trust

  [SwitchA-Ethernet1/0/1] am user-bind mac-addr 0001-0002-0003 ip-addr 10.12.1.1 # 将Host 1的MAC地址和IP地址绑定到Ethernet1/0/1端口。

  [ProviderA-Ethernet1/0/1-vid-1000] quit

  注意:缺省情况下,端口的链路类型为Access类型,所有Access端口均属于且只属于VLAN1

  [ProviderA-Ethernet1/0/1-vid-1000] raw-vlan-id inbound 10

  [Sysname-mst-region] instance 2 vlan 20 to 30

  [Switch-Ethernet1/0/1] port-security max-mac-count 80 # 设置端口允许接入的最大MAC地址数为80

   terminal debugging

  2、基本配置

  [SwitchA-Ethernet1/0/1] ip check source ip-address mac-address

  13、端口安全配置

  [SwitchA] gvrp # 开启全局GVRP

   debugging bfd event

  [Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0 ;配置VLAN的IP地址

  [Sysname-Ethernet1/0/2] port isolate

  [Quidway]port mirror ;指定被镜像端口

  9、MAC地址表的操作

  所以设置PVID为所属vlan id, 设置可以互通的vlan为untagged.

  [ProviderB-Ethernet1/0/1] qinq ethernet-type 8200 # 为与公共网络中的设备进行互通,配置端口添加外层Tag时采用的TPID值为0x8200。

  [Quidway]display mac-address aging-time ;显示地址表动态表项的老化时间

  [Quidway]mac-address { static | dynamic | blackhole } mac-address interface interface-type interface-number vlan vlan-id ;添加MAC地址表项

  [Quidway-Ethernet0/2]port trunk pvid vlan 3 ;设置trunk端口的PVID

  配置隔离组后,只有隔离组内各个端口之间的报文不能互通,隔离组内端口与隔离组外端口以及隔离组外端口之间的通信不会受到影响。

  Switch A、Switch B、Switch C相互可达,在Switch A上配置静态路由可以到达Switch C,并使能BFD检测功能。

  [SwitchA] interface gigabitethernet 1/1/1 # 配置端口工作在强制全双工模式,速率为1000Mbits/s。

  [S3026-ui-vty0-4]user privilege level 3 ;用户级别

  # 配置MST域名为info,MSTP修订级别为1,VLAN映射关系为VLAN2~VLAN10映射到生成树实例1上,VLAN20~VLAN30映射生成树实例2上。

  [Sysname-mst-region] active region-configuration

  14、端口绑定配置

  [ProviderA-Ethernet1/0/2] qinq enable # 配置端口的基本QinQ功能,将来自VLAN10的报文封装VLAN ID为1000的外层Tag。

  [SwitchA] dhcp-snooping # 开启DHCP Snooping功能。

   system-view

  [SwitchA] interface ethernet 1/0/2

  [Quidway]stp mode rstp ;设置生成树模式为rstp

  当光纤一端连接正确,一端未连接时:

  [ProviderA-Ethernet1/0/1-vid-2000] raw-vlan-id inbound 20

  将使用该协议预置的MAC地址作为源地址填充到报文中进行发送。在实际组网中,由于多台设备都使用相同的源MAC地址发送二层协议报文,会造成在某台设备的不

  [Quidway]display port-mac ;显示用户配置的以太网端口MAC地址的起始值

  [Quidway]display saved-configuration ;显示flash中配置文件,即下次上电启动时所用的配置文件

  [DeviceA] interface ethernet 1/0/1 ;将以太网端口Ethernet1/0/1加入聚合组1

  6、端口镜像

  4、端口配置

  [Quidway]sysname ;交换机命名

  [Sysname-mst-region] revision-level 1

  # 在Switch A上配置静态路由,并使能BFD检测功能,通过BFD echo报文方式实现BFD功能。

  [ProviderA-Ethernet1/0/1] port hybrid vlan 10 20 1000 2000 untagged

  [DeviceA-Ethernet1/0/1] interface ethernet 1/0/2 ;将以太网端口Ethernet1/0/1加入聚合组1

  [SwitchE-Ethernet1/0/1] gvrp registration { fixed | forbidden | normal } # 配置GVRP端口注册模式 缺省为normal

  [Quidway]description ;删除VLAN描述字符

  [DeviceA-Ethernet1/0/1] port link-aggregation group 1

  [DeviceA-Ethernet1/0/2] port link-aggregation group 1

  [Quidway]stp priority 4096 ;设置交换机的优先级

  [Quidway-Ethernet0/1]port link-type {trunk|access|hybrid} ;设置端口工作模式

  [SwitchA] dldp work-mode { enhance | normal } # 配置DLDP协议的工作模式为加强模式。 缺省为normal

  [Quidway-Ethernet0/1]flow-control ;配置端口流控

  [Quidway-Ethernet0/2]port link-type hybrid ;配置端口的链路类型为Hybrid类型

  [Quidway]stp {enable|disable} ;设置生成树,默认关闭

  [Quidway-Ethernet0/2]port hybrid pvid ;删除vlan的pvid

  [Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2 ;静态路由=网关

  [ProviderB-Ethernet1/0/1] quit

  [SwitchA] interface ethernet1/0/2 # 设置与DHCP服务器相连的端口Ethernet1/0/2为信任端口。

  [ProviderB] interface ethernet 1/0/1 # 配置端口为Trunk端口,且允许VLAN1000和VLAN2000的报文通过。

  [Quidway-Ethernet0/1]mdi {across|auto|normal} ;配置端口平接扭接

  [SwitchA] display gvrp statistics [ interface interface-list ] ;显示GVRP统计信息

  和Customer C的VLAN20的报文经过运营商网络的VLAN2000转发后互通。

  [SwitchA] dldp unidirectional-shutdown { auto | manual } # 配置DLDP单向链路操作模式为自动模式。 缺省为auto

  [Quidway-Ethernet0/2]mac-address { static | dynamic | blackhole } mac-address vlan vlan-id

  在系统视图下添加MAC地址表项

  通过端口隔离特性,用户可以将需要进行控制的端口加入到一个隔离组中,实现隔离组中的端口之间二层、三层数据的隔离,既增强了网络的安全性,也为用户

  [Quidway-Ethernet0/2]quit ;退出系统视图

  [Quidway-Ethernet0/2]mac-address max-mac-count count ;设置端口最多可以学习到的MAC地址数量

  对于既处于某个聚合组又处于某个隔离组的一组端口,其中的一个端口离开聚合组时不会影响其他端口,即其他端口仍将处于原聚合组和原隔离组中。

  1、配置文件相关命令

  [DeviceA] interface ethernet 1/0/1 # 将以太网端口Ethernet1/0/1加入业务环回组。

  [Quidway]display current-configuration ;显示当前生效的配置

  [DeviceA-Ethernet1/0/1] undo stp

  [SwitchA] interface ethernet1/0/1 # 配置端口Ethernet1/0/1的端口过滤功能。

  [SwitchA-Ethernet1/0/2] user-bind ip-address 192.168.0.3 mac-address 0001-0203-0405

  注意:缺省情况下,MAC地址表项的老化时间为300秒,使用参数no-aging时表示不对MAC地址表项进行老化。

  [Switch-Ethernet1/0/1] port-security intrusion-mode disableport-temporarily # 设置Intrusion Protection特性被触发后,暂时关闭该端口

  3、telnet配置

  [ProviderA] interface ethernet 1/0/2 # 配置端口的缺省VLAN为VLAN1000。

  [SwitchA]Isolate-user-vlan secondary

;设置主vlan包括的子vlan

  [Sysname] interface ethernet1/0/2 # 将以太网端口Ethernet1/0/2加入隔离组。

  [SwitchA-vlanx]isolate-user-vlan enable ;设置主vlan

  11、DLDP配置

  [Quidway-Ethernet0/2]port trunk permit vlan {ID|All} ;设trunk允许的VLAN

  [Quidway-Ethernet0/2]port hybrid pvid vlan vlan-id ;设置Hybrid端口的缺省VLAN

  当汇聚组中的某个端口加入或离开隔离组后,本设备中同一汇聚组内的其它端口,均会自动加入或离开该隔离组。

  [SwitchA] display gvrp statusreset garp statistics [ interface interface-list ] ;清除GARP统计信息

  reset saved-configuration ;檫除旧的配置文件

  端口过滤配置

  display version ;显示系统版本信息

  VLAN描述

  [DeviceA] link-aggregation group 1 mode manual ;创建手工聚合组1

  [Switch] interface Ethernet 1/0/1 # 进入以太网Ethernet1/0/1端口视图

  [SwitchA-vlan-interface10] quit

  [Sysname] stp region-configuration

  [SwitchA-vlan-interface10] bfd detect-multiplier 7

  [ProviderA-Ethernet1/0/3] port trunk permit vlan 1000 2000

  [DeviceA-Ethernet1/0/1] port link-aggregation group 1

  MSTP配置:

  15、BFD配置

  [Switch-Ethernet1/0/1] port-security port-mode autolearn # 配置端口的安全模式为autolearn

  [Quidway-vlan3]port ethernet 0/1 to ethernet 0/4 ;在VLAN中增加端口

  [Quidway]super password ;修改特权用户密码

  [SwitchA-GigabitEthernet1/1/1] duplex full

  [Quidway]user-interface vty 0 4 ;进入虚拟终端

  [SwitchA] interface vlan-interface 10

  [Quidway-Ethernet0/2]port link-type trunk ;设置当前端口为trunk

  在缺省情况下,E126/E126A交换机的以太网端口是没有配置MAC地址的,因此当交换机在发送二层协议报文(例如STP)时,由于无法取用发送端口的MAC地址,

  注意:缺省情况下,Hybrid端口的缺省VLAN为VLAN1

  [ProviderA-Ethernet1/0/1] qinq vid 1000 # 将来自VLAN10的报文封装VLAN ID为1000的外层Tag。

  端口隔离特性与以太网端口所属的VLAN无关。

  注意:缺省情况下,没有配置对端口学习MAC地址数量的限制。反之,如果端口启动了MAC地址认证和端口安全功能,则不能配置该端口的最大MAC地址学习个数。

  [Quidway]interface ethernet 0/1 ;进入接口视图

   debugging bfd scm

  当光纤交叉连接时,可能有两个或三个端口处于Disable状态,剩余端口处于Inactive状态。

  [Quidway]display vlan [vlan_id] ;查看VLAN设置

  希望配置完成后达到下列要求:

  dldp reset命令在全局下可以重置所有端口的DLDP状态,在接口下可以充值该端口的DLDP状态

  [Switch] port-security enable # 启动端口安全功能

  址的用户发出的报文进行转发,提高了系统的安全性,增强了对网络安全的监控。

  配置基于trunk的VLAN

  [Quidway-Ethernet0/1]stp cost 200 ;设置交换机端口的花费

  [Switch]port-security timer disableport 30 # 关闭时间为30秒。

  Provider A和Provider B之间,运营商采用其他厂商的设备,TPID值为0x8200。

相关推荐:

  • []

Copyright©2007-2016 www.zn51.com, All rights reserved.  中南教育信息网 版权所有  鄂ICP备14013969号-2

声明※本网站发布的信息版权归原作者所有,如需商业用途或转载请与原作者联系。如有文章侵犯作者权利,违规,请联系本站删除

Top